Vulnerabilities (CVE)

Filtered by CWE-94
Total 7625 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2021-25283 3 Debian, Fedoraproject, Saltstack 3 Debian Linux, Fedora, Salt 2026-06-17 7.5 HIGH 9.8 CRITICAL
An issue was discovered in through SaltStack Salt before 3002.5. The jinja renderer does not protect against server side template injection attacks.
CVE-2021-25251 2 Microsoft, Trendmicro 9 Windows, Antivirus\+ Security 2020, Antivirus\+ Security 2021 and 6 more 2026-06-17 6.5 MEDIUM 7.2 HIGH
The Trend Micro Security 2020 and 2021 families of consumer products are vulnerable to a code injection vulnerability which could allow an attacker to disable the program's password protection and disable protection. An attacker must already have administrator privileges on the machine to exploit this vulnerability.
CVE-2021-25003 1 Wptaskforce 1 Wpcargo Track \& Trace 2026-06-17 7.5 HIGH 9.8 CRITICAL
The WPCargo Track & Trace WordPress plugin before 6.9.0 contains a file which could allow unauthenticated attackers to write a PHP file anywhere on the web server, leading to RCE
CVE-2021-24721 1 Loco Translate Project 1 Loco Translate 2026-06-17 4.0 MEDIUM 6.5 MEDIUM
The Loco Translate WordPress plugin before 2.5.4 mishandles data inputs which get saved to a file, which can be renamed to an extension ending in .php, resulting in authenticated "translator" users being able to inject PHP code into files ending with .php in web accessible locations.
CVE-2021-24546 1 Extendify 1 Editorskit 2026-06-17 6.5 MEDIUM 8.8 HIGH
The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code
CVE-2021-24537 1 Shareaholic 1 Similar Posts 2026-06-17 6.0 MEDIUM 7.2 HIGH
The Similar Posts WordPress plugin through 3.1.5 allow high privilege users to execute arbitrary PHP code in an hardened environment (ie with DISALLOW_FILE_EDIT, DISALLOW_FILE_MODS and DISALLOW_UNFILTERED_HTML set to true) via the 'widget_rrm_similar_posts_condition' widget setting of the plugin.
CVE-2021-24430 1 Optimocha 1 Speed Booster Pack 2026-06-17 6.5 MEDIUM 7.2 HIGH
The Speed Booster Pack ⚡ PageSpeed Optimization Suite WordPress plugin before 4.2.0 did not validate its caching_exclude_urls and caching_include_query_strings settings before outputting them in a PHP file, which could lead to RCE
CVE-2021-24312 1 Automattic 1 Wp Super Cache 2026-06-17 6.5 MEDIUM 7.2 HIGH
The parameters $cache_path, $wp_cache_debug_ip, $wp_super_cache_front_page_text, $cache_scheduled_time, $cached_direct_pages used in the settings of WP Super Cache WordPress plugin before 1.7.3 result in RCE because they allow input of '$' and '\n'. This is due to an incomplete fix of CVE-2021-24209.
CVE-2021-24209 1 Automattic 1 Wp Super Cache 2026-06-17 9.0 HIGH 7.2 HIGH
The WP Super Cache WordPress plugin before 1.7.2 was affected by an authenticated (admin+) RCE in the settings page due to input validation failure and weak $cache_path check in the WP Super Cache Settings -> Cache Location option. Direct access to the wp-cache-config.php file is not prohibited, so this vulnerability can be exploited for a web shell injection.
CVE-2021-23814 1 Unisharp 1 Laravel-filemanager 2026-06-17 6.5 MEDIUM 6.7 MEDIUM
This affects versions of the package unisharp/laravel-filemanager before 2.6.2. The upload() function does not sufficiently validate the file type when uploading. An attacker may be able to reproduce the following steps: 1. Install a package with a web Laravel application. 2. Navigate to the Upload window 3. Upload an image file, then capture the request 4. Edit the request contents with a malicious file (webshell) 5. Enter the path of file uploaded on URL - Remote Code Execution **Note:** Prevention for bad extensions can be done by using a whitelist in the config file(lfm.php). Corresponding document can be found in [here](https://unisharp.github.io/laravel-filemanager/configfolder-categories).
CVE-2021-23390 1 Totaljs 1 Total4 2026-06-17 7.5 HIGH 9.8 CRITICAL
The package total4 before 0.0.43 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
CVE-2021-23389 1 Totaljs 1 Total.js 2026-06-17 7.5 HIGH 9.8 CRITICAL
The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
CVE-2021-23358 4 Debian, Fedoraproject, Tenable and 1 more 4 Debian Linux, Fedora, Tenable.sc and 1 more 2026-06-17 6.5 MEDIUM 3.3 LOW
The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.
CVE-2021-23344 1 Totaljs 1 Total.js 2026-06-17 7.5 HIGH 9.8 CRITICAL
The package total.js before 3.4.8 are vulnerable to Remote Code Execution (RCE) via set.
CVE-2021-23281 1 Eaton 1 Intelligent Power Manager 2026-06-17 7.5 HIGH 10.0 CRITICAL
Eaton Intelligent Power Manager (IPM) prior to 1.69 is vulnerable to unauthenticated remote code execution vulnerability. IPM software does not sanitize the date provided via coverterCheckList action in meta_driver_srv.js class. Attackers can send a specially crafted packet to make IPM connect to rouge SNMP server and execute attacker-controlled code.
CVE-2021-23277 1 Eaton 3 Intelligent Power Manager, Intelligent Power Manager Virtual Appliance, Intelligent Power Protector 2026-06-17 7.5 HIGH 8.3 HIGH
Eaton Intelligent Power Manager (IPM) prior to 1.69 is vulnerable to unauthenticated eval injection vulnerability. The software does not neutralize code syntax from users before using in the dynamic evaluation call in loadUserFile function under scripts/libs/utils.js. Successful exploitation can allow attackers to control the input to the function and execute attacker controlled commands.
CVE-2021-23154 1 Mirantis 1 Lens 2026-06-17 9.3 HIGH 6.3 MEDIUM
In Lens prior to 5.3.4, custom helm chart configuration creates helm commands from string concatenation of provided arguments which are then executed in the user's shell. Arguments can be provided which cause arbitrary shell commands to run on the system.
CVE-2021-22961 1 Glasswire 1 Glasswire 2026-06-17 7.5 HIGH 9.8 CRITICAL
A code injection vulnerability exists within the firewall software of GlassWire v2.1.167 that could lead to arbitrary code execution from a file in the user path on first execution.
CVE-2021-22952 1 Ui 1 Unifi Talk 2026-06-17 6.5 MEDIUM 8.8 HIGH
A vulnerability found in UniFi Talk application V1.12.3 and earlier permits a malicious actor who has already gained access to a network to subsequently control Talk device(s) assigned to said network if they are not yet adopted. This vulnerability is fixed in UniFi Talk application V1.12.5 and later.
CVE-2021-22900 2 Ivanti, Pulsesecure 2 Connect Secure, Pulse Connect Secure 2026-06-17 6.5 MEDIUM 7.2 HIGH
A vulnerability allowed multiple unrestricted uploads in Pulse Connect Secure before 9.1R11.4 that could lead to an authenticated administrator to perform a file write via a maliciously crafted archive upload in the administrator web interface.