Vulnerabilities (CVE)

Filtered by CWE-94
Total 7625 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-22270 1 Google 1 Android 2026-06-17 4.3 MEDIUM 4.4 MEDIUM
An implicit Intent hijacking vulnerability in Dialer prior to SMR Jan-2022 Release 1 allows unprivileged applications to access contact information.
CVE-2022-21831 2 Debian, Rubyonrails 2 Debian Linux, Active Storage 2026-06-17 6.8 MEDIUM 9.8 CRITICAL
A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.
CVE-2022-21797 3 Debian, Fedoraproject, Joblib Project 3 Debian Linux, Fedora, Joblib 2026-06-17 N/A 7.3 HIGH
The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.
CVE-2022-21686 1 Prestashop 1 Prestashop 2026-06-17 7.5 HIGH 9.0 CRITICAL
PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.
CVE-2022-21122 1 Metarhia 1 Metacalc 2026-06-17 7.5 HIGH 9.0 CRITICAL
The package metacalc before 0.0.2 are vulnerable to Arbitrary Code Execution when it exposes JavaScript's Math class to the v8 context. As the Math class is exposed to user-land, it can be used to get access to JavaScript's Function constructor.
CVE-2022-1609 1 Weblizar 1 School Management 2026-06-17 N/A 9.8 CRITICAL
The School Management WordPress plugin before 9.9.7 contains an obfuscated backdoor injected in it's license checking code that registers a REST API handler, allowing an unauthenticated attacker to execute arbitrary PHP code on the site.
CVE-2022-1575 1 Diagrams 1 Drawio 2026-06-17 6.8 MEDIUM 9.6 CRITICAL
Arbitrary Code Execution through Sanitizer Bypass in GitHub repository jgraph/drawio prior to 18.0.0. - Arbitrary (remote) code execution in the desktop app. - Stored XSS in the web app.
CVE-2022-1159 1 Rockwellautomation 10 Compact Guardlogix 5380, Compact Guardlogix 5380 Firmware, Compactlogix 5380 and 7 more 2026-06-17 6.5 MEDIUM 7.7 HIGH
Rockwell Automation Studio 5000 Logix Designer (all versions) are vulnerable when an attacker who achieves administrator access on a workstation running Studio 5000 Logix Designer could inject controller code undetectable to a user.
CVE-2022-0944 1 Sqlpad 1 Sqlpad 2026-06-17 6.5 MEDIUM 7.2 HIGH
Template injection in connection test endpoint leads to RCE in GitHub repository sqlpad/sqlpad prior to 6.10.1.
CVE-2022-0921 1 Microweber 1 Microweber 2026-06-17 6.5 MEDIUM 6.7 MEDIUM
Abusing Backup/Restore feature to achieve Remote Code Execution in GitHub repository microweber/microweber prior to 1.2.12.
CVE-2022-0896 1 Microweber 1 Microweber 2026-06-17 6.8 MEDIUM 8.8 HIGH
Improper Neutralization of Special Elements Used in a Template Engine in GitHub repository microweber/microweber prior to 1.3.
CVE-2022-0885 1 Memberhero 1 Member Hero 2026-06-17 7.5 HIGH 9.8 CRITICAL
The Member Hero WordPress plugin through 1.0.9 lacks authorization checks, and does not validate the a request parameter in an AJAX action, allowing unauthenticated users to call arbitrary PHP functions with no arguments.
CVE-2022-0845 1 Lightningai 1 Pytorch Lightning 2026-06-17 10.0 HIGH 9.8 CRITICAL
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
CVE-2022-0819 1 Dolibarr 1 Dolibarr Erp\/crm 2026-06-17 6.5 MEDIUM 8.8 HIGH
Code Injection in GitHub repository dolibarr/dolibarr prior to 15.0.1.
CVE-2022-0811 1 Kubernetes 1 Cri-o 2026-06-17 9.0 HIGH 8.8 HIGH
A flaw was found in CRI-O in the way it set kernel options for a pod. This issue allows anyone with rights to deploy a pod on a Kubernetes cluster that uses the CRI-O runtime to achieve a container escape and arbitrary code execution as root on the cluster node, where the malicious pod was deployed.
CVE-2022-0661 1 Ad Injection Project 1 Ad Injection 2026-06-17 6.5 MEDIUM 7.2 HIGH
The Ad Injection WordPress plugin through 1.2.0.19 does not properly sanitize the body of the adverts injected into the pages, allowing a high privileged user (Admin+) to inject arbitrary HTML or javascript even with unfiltered_html disallowed, leading to a stored cross-site scripting (XSS) vulnerability. Further it is also possible to inject PHP code, leading to a Remote Code execution (RCE) vulnerability, even if the DISALLOW_FILE_EDIT and DISALLOW_FILE_MOD constants are both set.
CVE-2022-0578 1 Publify Project 1 Publify 2026-06-17 6.4 MEDIUM 6.5 MEDIUM
Code Injection in GitHub repository publify/publify prior to 9.2.8.
CVE-2022-0323 1 Mustache Project 1 Mustache 2026-06-17 6.5 MEDIUM 8.8 HIGH
Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1.
CVE-2021-4434 1 Warfareplugins 1 Social Warfare 2026-06-17 N/A 10.0 CRITICAL
The Social Warfare plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 3.5.2 via the 'swp_url' parameter. This allows attackers to execute code on the server.
CVE-2021-4315 1 Psiturk 1 Psiturk 2026-06-17 5.2 MEDIUM 5.5 MEDIUM
A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.