Vulnerabilities (CVE)

Filtered by CWE-77
Total 3981 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2019-12736 1 Jetbrains 1 Ktor 2026-06-17 7.5 HIGH 9.8 CRITICAL
JetBrains Ktor framework before 1.2.0-rc does not sanitize the username provided by the user for the LDAP protocol, leading to command injection.
CVE-2019-12661 1 Cisco 1 Ios Xe 2026-06-17 7.2 HIGH 6.7 MEDIUM
A vulnerability in a Virtualization Manager (VMAN) related CLI command of Cisco IOS XE Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying Linux operating system with a privilege level of root. The vulnerability is due to insufficient validation of arguments passed to a specific VMAN CLI command on the affected device. An attacker who has administrator access to an affected device could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the device with root privileges, which may lead to complete system compromise.
CVE-2019-12651 1 Cisco 5 Cloud Services Router 1000v, Cloud Services Router 1000v Firmware, Integrated Services Virtual Router and 2 more 2026-06-17 9.0 HIGH 8.8 HIGH
Multiple vulnerabilities in the web-based user interface (Web UI) of Cisco IOS XE Software could allow an authenticated, remote attacker to execute commands with elevated privileges on the affected device. For more information about these vulnerabilities, see the Details section of this advisory.
CVE-2019-12650 1 Cisco 79 1100-4p Integrated Services Router, 1100-8p Integrated Services Router, 1101-4p Integrated Services Router and 76 more 2026-06-17 9.0 HIGH 8.8 HIGH
Multiple vulnerabilities in the web-based user interface (Web UI) of Cisco IOS XE Software could allow an authenticated, remote attacker to execute commands with elevated privileges on the affected device. For more information about these vulnerabilities, see the Details section of this advisory.
CVE-2019-12629 1 Cisco 8 Sd-wan Firmware, Vedge-100, Vedge-1000 and 5 more 2026-06-17 9.0 HIGH 7.2 HIGH
A vulnerability in the WebUI of the Cisco SD-WAN Solution could allow an authenticated, remote attacker to inject and execute arbitrary commands with vmanage user privileges on an affected system. The vulnerability is due to insufficient input validation of data parameters for certain fields in the affected solution. An attacker could exploit this vulnerability by configuring a malicious username on the login page of the affected solution. A successful exploit could allow the attacker to inject and execute arbitrary commands with vmanage user privileges on an affected system.
CVE-2019-12591 1 Netgear 1 Insight 2026-06-17 6.5 MEDIUM 6.8 MEDIUM
NETGEAR Insight Cloud with firmware before Insight 5.6 allows remote authenticated users to achieve command injection.
CVE-2019-12430 1 Gitlab 1 Gitlab 2026-06-17 6.5 MEDIUM 8.8 HIGH
An issue was discovered in GitLab Community and Enterprise Edition 11.11. A specially crafted payload would allow an authenticated malicious user to execute commands remotely through the repository download feature. It allows Command Injection.
CVE-2019-12104 1 Tp-link 2 M7350, M7350 Firmware 2026-06-17 9.0 HIGH 8.8 HIGH
The web-based configuration interface of the TP-Link M7350 V3 with firmware before 190531 is affected by several post-authentication command injection vulnerabilities.
CVE-2019-11853 1 Sierrawireless 9 Airlink Es450, Airlink Gx450, Airlink Lx40 and 6 more 2026-06-17 6.5 MEDIUM 3.9 LOW
Several potential command injections vulnerabilities exist in the AT command interface of ALEOS before 4.11.0, and 4.9.4.
CVE-2019-11535 1 Linksys 4 Re6300, Re6300 Firmware, Re6400 and 1 more 2026-06-17 10.0 HIGH 9.8 CRITICAL
Unsanitized user input in the web interface for Linksys WiFi extender products (RE6400 and RE6300 through 1.2.04.022) allows for remote command execution. An attacker can access system OS configurations and commands that are not intended for use beyond the web UI.
CVE-2019-11279 1 Cloudfoundry 1 Uaa Release 2026-06-17 6.5 MEDIUM 8.8 HIGH
CF UAA versions prior to 74.1.0 can request scopes for a client that shouldn't be allowed by submitting an array of requested scopes. A remote malicious user can escalate their own privileges to any scope, allowing them to take control of UAA and the resources it controls.
CVE-2019-11278 1 Cloudfoundry 1 User Account And Authentication 2026-06-17 6.5 MEDIUM 8.8 HIGH
CF UAA versions prior to 74.1.0, allow external input to be directly queried against. A remote malicious user with 'client.write' and 'groups.update' can craft a SCIM query, which leaks information that allows an escalation of privileges, ultimately allowing the malicious user to gain control of UAA scopes they should not have.
CVE-2019-11217 1 Bonobogitserver 1 Bonobo Git Server 2026-06-17 7.5 HIGH 9.8 CRITICAL
The GitController in Jakub Chodounsky Bonobo Git Server before 6.5.0 allows execution of arbitrary commands in the context of the web server via a crafted http request.
CVE-2019-11076 1 Cribl 1 Cribl 2026-06-17 7.5 HIGH 9.8 CRITICAL
Cribl UI 1.5.0 allows remote attackers to run arbitrary commands via an unauthenticated web request.
CVE-2019-10854 1 Computrols 1 Computrols Building Automation Software 2026-06-17 9.0 HIGH 8.8 HIGH
Computrols CBAS 18.0.0 allows Authenticated Command Injection.
CVE-2019-10640 1 Gitlab 1 Gitlab 2026-06-17 5.0 MEDIUM 7.5 HIGH
An issue was discovered in GitLab Community and Enterprise Edition before 11.7.10, 11.8.x before 11.8.6, and 11.9.x before 11.9.4. A regex input validation issue for the .gitlab-ci.yml refs value allows Uncontrolled Resource Consumption.
CVE-2019-10095 1 Apache 1 Zeppelin 2026-06-17 10.0 HIGH 9.8 CRITICAL
bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.
CVE-2019-1010174 2 Cimg, Debian 2 Cimg Library, Debian Linux 2026-06-17 7.5 HIGH 9.8 CRITICAL
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
CVE-2019-1000018 4 Canonical, Debian, Fedoraproject and 1 more 4 Ubuntu Linux, Debian Linux, Fedora and 1 more 2026-06-17 4.6 MEDIUM 7.8 HIGH
rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.
CVE-2019-0541 1 Microsoft 18 Excel Viewer, Internet Explorer, Office and 15 more 2026-06-17 9.3 HIGH 8.8 HIGH
A remote code execution vulnerability exists in the way that the MSHTML engine inproperly validates input, aka "MSHTML Engine Remote Code Execution Vulnerability." This affects Microsoft Office, Microsoft Office Word Viewer, Internet Explorer 9, Internet Explorer 11, Microsoft Excel Viewer, Internet Explorer 10, Office 365 ProPlus.