CVE-2026-45205

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:*

History

26 Oct 2026, 14:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de recursión incontrolada en Apache Commons. Al procesar un archivo de configuración no confiable, Commons Configuration lanzará un StackOverflowError para entradas YAML con ciclos. Este problema afecta a Apache Commons: desde la versión 2.2 hasta antes de la 2.15.0. Se recomienda a los usuarios actualizar a la versión 2.15.0, que corrige el problema.

Information

Published : 2026-05-14 12:16

Updated : 2026-10-26 14:10


NVD link : CVE-2026-45205

Mitre link : CVE-2026-45205

CVE.ORG link : CVE-2026-45205


JSON object : View

Products Affected

apache

  • commons_configuration
CWE
CWE-674

Uncontrolled Recursion