CVE-2026-39304

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*

History

26 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Denegación de servicio a través de una vulnerabilidad de falta de memoria en Apache ActiveMQ Cliente, Apache ActiveMQ Broker, Apache ActiveMQ. Los transportes SSL NIO de ActiveMQ no manejan correctamente las actualizaciones de clave de handshake de TLSv1.3 activadas por clientes. Esto hace posible que un cliente active rápidamente actualizaciones, lo que provoca que el broker agote toda su memoria en el motor SSL, lo que lleva a DoS. Nota: Las versiones de TLS anteriores a TLSv1.3 (como TLSv1.2) están rotas pero no son vulnerables a OOM. Las versiones anteriores de TLS requieren una renegociación completa del handshake, lo que provoca que una conexión se cuelgue pero no OOM. Esto también está solucionado. Este problema afecta a Apache ActiveMQ Cliente: antes de 5.19.4, desde 6.0.0 antes de 6.2.4; Apache ActiveMQ Broker: antes de 5.19.4, desde 6.0.0 antes de 6.2.4; Apache ActiveMQ: antes de 5.19.4, desde 6.0.0 antes de 6.2.4. Se recomienda a los usuarios que actualicen a la versión 6.2.4 o 5.19.5, lo que soluciona el problema.

Information

Published : 2026-04-10 11:16

Updated : 2026-10-26 21:10


NVD link : CVE-2026-39304

Mitre link : CVE-2026-39304

CVE.ORG link : CVE-2026-39304


JSON object : View

Products Affected

apache

  • activemq
  • activemq_broker
CWE
CWE-400

Uncontrolled Resource Consumption

CWE-770

Allocation of Resources Without Limits or Throttling