CVE-2025-55754

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

History

08 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Neutralización Incorrecta de Secuencias de Escape, Meta o Control en Apache Tomcat. Tomcat no escapaba las secuencias de escape ANSI en los mensajes de registro. Si Tomcat se ejecutaba en una consola en un sistema operativo Windows, y la consola soportaba secuencias de escape ANSI, era posible para un atacante usar una URL especialmente diseñada para inyectar secuencias de escape ANSI para manipular la consola y el portapapeles e intentar engañar a un administrador para que ejecutara un comando controlado por el atacante. Aunque no se encontró ningún vector de ataque, podría haber sido posible montar este ataque en otros sistemas operativos. Este problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.10, desde 10.1.0-M1 hasta 10.1.44, desde 9.0.40 hasta 9.0.108. Las siguientes versiones estaban al final de su vida útil (EOL) en el momento en que se creó el CVE, pero se sabe que están afectadas: 8.5.60 hasta 8.5.100. Otras versiones más antiguas, EOL, también pueden estar afectadas. Se recomienda a los usuarios actualizar a la versión 11.0.11 o posterior, 10.1.45 o posterior o 9.0.109 o posterior, que solucionan el problema.

Information

Published : 2025-10-27 18:15

Updated : 2026-10-08 11:10


NVD link : CVE-2025-55754

Mitre link : CVE-2025-55754

CVE.ORG link : CVE-2025-55754


JSON object : View

Products Affected

apache

  • tomcat
CWE
CWE-150

Improper Neutralization of Escape, Meta, or Control Sequences