Total
32 CVE
| CVE | Vendors | Products | Updated | CVSS v2 | CVSS v3 |
|---|---|---|---|---|---|
| CVE-2026-41602 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 7.5 HIGH |
| Integer Overflow or Wraparound vulnerability in Apache Thrift TFramedTransport Go language implementation This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-41606 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 5.3 MEDIUM |
| Uncontrolled Recursion vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-41636 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 7.5 HIGH |
| Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-41605 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 7.3 HIGH |
| Integer Overflow or Wraparound vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-41604 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 8.2 HIGH |
| Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-43868 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 5.3 MEDIUM |
| Memory Allocation with Excessive Size Value vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-43869 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 7.3 HIGH |
| Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-43870 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 7.3 HIGH |
| Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-41607 | 1 Apache | 1 Thrift | 2026-10-26 | N/A | 6.5 MEDIUM |
| Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. | |||||
| CVE-2026-55971 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 9.8 CRITICAL |
| Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-48586 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-55968 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Inefficient Algorithmic Complexity, Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Node.js bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-49158 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-45112 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: from 0.19.0 before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-48145 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-58023 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 9.1 CRITICAL |
| Out-of-bounds Read vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-41608 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-55970 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 6.5 MEDIUM |
| Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-58389 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 7.5 HIGH |
| Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Rust bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. | |||||
| CVE-2026-66053 | 1 Apache | 1 Thrift | 2026-10-24 | N/A | 5.9 MEDIUM |
| Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603 | |||||
