Vulnerabilities (CVE)

Filtered by CWE-94
Total 7624 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2023-5550 2 Fedoraproject, Moodle 3 Extra Packages For Enterprise Linux, Fedora, Moodle 2026-06-17 N/A 6.5 MEDIUM
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
CVE-2023-5540 2 Fedoraproject, Moodle 3 Extra Packages For Enterprise Linux, Fedora, Moodle 2026-06-17 N/A 4.7 MEDIUM
A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.
CVE-2023-5539 2 Fedoraproject, Moodle 3 Extra Packages For Enterprise Linux, Fedora, Moodle 2026-06-17 N/A 4.7 MEDIUM
A remote code execution risk was identified in the Lesson activity. By default this was only available to teachers and managers.
CVE-2023-5512 1 Gitlab 1 Gitlab 2026-06-17 N/A 4.8 MEDIUM
An issue has been discovered in GitLab CE/EE affecting all versions from 16.3 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. File integrity may be compromised when specific HTML encoding is used for file names leading for incorrect representation in the UI.
CVE-2023-5500 1 Frauscher 1 Frauscher Diagnostic System 102 2026-06-17 N/A 8.8 HIGH
This vulnerability allows an remote attacker with low privileges to misuse Improper Control of Generation of Code ('Code Injection') to gain full control of the affected device.
CVE-2023-5226 1 Gitlab 1 Gitlab 2026-06-17 N/A 4.8 MEDIUM
An issue has been discovered in GitLab affecting all versions before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. Under certain circumstances, a malicious actor bypass prohibited branch checks using a specially crafted branch name to manipulate repository content in the UI.
CVE-2023-5221 1 Foru Cms Project 1 Foru Cms 2026-06-17 5.8 MEDIUM 4.7 MEDIUM
A vulnerability classified as critical has been found in ForU CMS. This affects an unknown part of the file /install/index.php. The manipulation of the argument db_name leads to code injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. This product does not use versioning. This is why information about affected and unaffected releases are unavailable. The associated identifier of this vulnerability is VDB-240363. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.
CVE-2023-5201 1 Rickbeckman 1 Openhook 2026-06-17 N/A 9.9 CRITICAL
The OpenHook plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 4.3.0 via the 'php' shortcode. This allows authenticated attackers with subscriber-level permissions or above, to execute code on the server. This requires the [php] shortcode setting to be enabled on the vulnerable site.
CVE-2023-5044 1 Kubernetes 1 Ingress-nginx 2026-06-17 N/A 7.6 HIGH
Code injection via nginx.ingress.kubernetes.io/permanent-redirect annotation.
CVE-2023-53940 2026-06-17 N/A 7.8 HIGH
Codigo Markdown Editor 1.0.1 contains a code execution vulnerability that allows attackers to run arbitrary system commands by crafting a malicious markdown file. Attackers can embed a video source with an onerror event that executes shell commands through Node.js child_process module when the file is opened.
CVE-2023-53888 1 Zomp 1 Zomplog 2026-06-17 N/A 8.8 HIGH
Zomplog 3.9 contains a remote code execution vulnerability that allows authenticated attackers to inject and execute arbitrary PHP code through file manipulation endpoints. Attackers can upload files (such as JavaScript) and rename them to .php via the saveE and rename actions, then execute the resulting PHP payload to run system commands.
CVE-2023-53883 1 Webedition 1 Webedition Cms 2026-06-17 N/A 7.2 HIGH
Webedition CMS v2.9.8.8 contains a remote code execution vulnerability that allows authenticated attackers to inject system commands through PHP page creation. Attackers can create a new PHP page with malicious system commands in the description field to execute arbitrary commands on the server.
CVE-2023-52381 1 Huawei 2 Emui, Harmonyos 2026-06-17 N/A 9.8 CRITICAL
Script injection vulnerability in the email module.Successful exploitation of this vulnerability may affect service confidentiality, integrity, and availability.
CVE-2023-51820 1 Blurams 2 Lumi Security Camera A31c, Lumi Security Camera A31c Firmware 2026-06-17 N/A 6.8 MEDIUM
An issue in Blurams Lumi Security Camera (A31C) v.2.3.38.12558 allows a physically proximate attackers to execute arbitrary code.
CVE-2023-51801 1 Oretnom23 1 Simple Student Attendance System 2026-06-17 N/A 9.8 CRITICAL
SQL Injection vulnerability in the Simple Student Attendance System v.1.0 allows a remote attacker to execute arbitrary code via a crafted payload to the id parameter in the student_form.php and the class_form.php pages.
CVE-2023-51797 2 Fedoraproject, Ffmpeg 2 Fedora, Ffmpeg 2026-06-17 N/A 6.7 MEDIUM
Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavfilter/avf_showwaves.c:722:24 in showwaves_filter_frame
CVE-2023-51784 1 Apache 1 Inlong 2026-06-17 N/A 9.8 CRITICAL
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.9.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9329
CVE-2023-51770 1 Apache 1 Dolphinscheduler 2026-06-17 N/A 7.5 HIGH
Arbitrary File Read Vulnerability in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.1. We recommend users to upgrade Apache DolphinScheduler to version 3.2.1, which fixes the issue.
CVE-2023-51420 1 Soft8soft 1 Verge3d 2026-06-17 N/A 9.1 CRITICAL
Improper Control of Generation of Code ('Code Injection') vulnerability in Soft8Soft LLC Verge3D Publishing and E-Commerce.This issue affects Verge3D Publishing and E-Commerce: from n/a through 4.5.2.
CVE-2023-51387 1 Apache 1 Hertzbeat 2026-06-17 N/A 7.2 HIGH
Hertzbeat is an open source, real-time monitoring system. Hertzbeat uses aviatorscript to evaluate alert expressions. The alert expressions are supposed to be some simple expressions. However, due to improper sanitization for alert expressions in version prior to 1.4.1, a malicious user can use a crafted alert expression to execute any command on hertzbeat server. A malicious user who has access to alert define function can execute any command in hertzbeat instance. This issue is fixed in version 1.4.1.