Vulnerabilities (CVE)

Filtered by CWE-74
Total 5717 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2017-17515 2 Debian, Ecmwf 2 Debian Linux, Metview 2026-06-17 6.8 MEDIUM 8.8 HIGH
etc/ObjectList in Metview 4.7.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL. NOTE: a third party has indicated that the code to access this environment variable is not enabled in the shipped product
CVE-2017-17514 2 Debian, Nip2 Project 2 Debian Linux, Nip2 2026-06-17 6.8 MEDIUM 8.8 HIGH
boxes.c in nip2 8.4.0 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL. NOTE: a software maintainer indicates that this product does not use the BROWSER environment variable
CVE-2017-17513 1 Tug 1 Tex Live 2026-06-17 6.8 MEDIUM 8.8 HIGH
TeX Live through 20170524 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, related to linked_scripts/context/stubs/unix/mtxrun, texmf-dist/scripts/context/stubs/mswin/mtxrun.lua, and texmf-dist/tex/luatex/lualibs/lualibs-os.lua.
CVE-2017-17511 2 Debian, Kildclient 2 Debian Linux, Kildclient 2026-06-17 6.8 MEDIUM 8.8 HIGH
KildClient 3.1.0 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, related to prefs.c and worldgui.c.
CVE-2017-16766 1 Synology 1 Diskstation Manager 2026-06-17 6.4 MEDIUM 6.5 MEDIUM
An improper access control vulnerability in synodsmnotify in Synology DiskStation Manager (DSM) before 6.1.4-15217 and before 6.0.3-8754-6 allows local users to inject arbitrary web script or HTML via the -fn option.
CVE-2017-16719 1 Moxa 6 Nport 5110, Nport 5110 Firmware, Nport 5130 and 3 more 2026-06-17 5.0 MEDIUM 7.5 HIGH
An Injection issue was discovered in Moxa NPort 5110 Version 2.2, NPort 5110 Version 2.4, NPort 5110 Version 2.6, NPort 5110 Version 2.7, NPort 5130 Version 3.7 and prior, and NPort 5150 Version 3.7 and prior. An attacker may be able to inject packets that could potentially disrupt the availability of the device.
CVE-2017-16680 1 Sap 1 Hana Extended Application Services 2026-06-17 5.0 MEDIUM 7.5 HIGH
Two potential audit log injections in SAP HANA extended application services 1.0, advanced model: 1) Certain HTTP/REST endpoints of controller service are missing user input validation which could allow unprivileged attackers to forge audit log lines. Hence the interpretation of audit log files could be hindered or misdirected. 2) User Account and Authentication writes audit logs into syslog and additionally writes the same audit entries into a log file. Entries in the log file miss escaping. Hence the interpretation of audit log files could be hindered or misdirected, while the entries in syslog are correct.
CVE-2017-16043 1 Shout Project 1 Shout 2026-06-17 4.3 MEDIUM 6.1 MEDIUM
Shout is an IRC client. Because the `/topic` command in messages is unescaped, attackers have the ability to inject HTML scripts that will run in the victim's browser. Affects shout >=0.44.0 <=0.49.3.
CVE-2017-15714 1 Apache 1 Ofbiz 2026-06-17 7.5 HIGH 9.8 CRITICAL
The BIRT plugin in Apache OFBiz 16.11.01 to 16.11.03 does not escape user input property passed. This allows for code injection by passing that code through the URL. For example by appending this code "__format=%27;alert(%27xss%27)" to the URL an alert window would execute.
CVE-2017-15708 2 Apache, Oracle 3 Synapse, Financial Services Market Risk Measurement And Management, Peoplesoft Enterprise Peopletools 2026-06-17 7.5 HIGH 9.8 CRITICAL
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
CVE-2017-15313 1 Huawei 1 Smartcare 2026-06-17 6.5 MEDIUM 8.8 HIGH
Huawei SmartCare V200R003C10 has a CSV injection vulnerability. An remote authenticated attacker could inject malicious CSV expression to the affected device.
CVE-2017-14523 1 Wondercms 1 Wondercms 2026-06-17 5.0 MEDIUM 7.5 HIGH
WonderCMS 2.3.1 is vulnerable to an HTTP Host header injection attack. It uses user-entered values to redirect pages. NOTE: the vendor reports that exploitation is unlikely because the attack can only come from a local machine or from the administrator as a self attack
CVE-2017-14397 2 Anydesk, Microsoft 2 Anydesk, Windows 2026-06-17 7.5 HIGH 9.8 CRITICAL
AnyDesk before 3.6.1 on Windows has a DLL injection vulnerability.
CVE-2017-14094 1 Trendmicro 1 Smart Protection Server 2026-06-17 7.5 HIGH 9.8 CRITICAL
A vulnerability in Trend Micro Smart Protection Server (Standalone) versions 3.2 and below could allow an attacker to perform remote command execution via a cron job injection on a vulnerable system.
CVE-2017-10963 1 Samsung 2 Knox Enterprise Mobility Management, Knox Identity Access Management 2026-06-17 4.3 MEDIUM 5.9 MEDIUM
In Knox SDS IAM (Identity Access Management) and EMM (Enterprise Mobility Management) 16.11 on Samsung mobile devices, a man-in-the-middle attacker can install any application into the Knox container (without the user's knowledge) by inspecting network traffic from a Samsung server and injecting content at a certain point in the update sequence. This installed application can further leak information stored inside the Knox container to the outside world.
CVE-2017-1000493 1 Rocket.chat 1 Rocket.chat 2026-06-17 7.5 HIGH 9.8 CRITICAL
Rocket.Chat Server version 0.59 and prior is vulnerable to a NoSQL injection leading to administrator account takeover
CVE-2017-1000454 1 Cmsmadesimple 1 Cms Made Simple 2026-06-17 4.6 MEDIUM 7.8 HIGH
CMS Made Simple 2.1.6, 2.2, 2.2.1 are vulnerable to Smarty Template Injection in some core components, resulting in local file read before 2.2, and local file inclusion since 2.2.1
CVE-2017-1000453 1 Cmsmadesimple 1 Cms Made Simple 2026-06-17 7.5 HIGH 9.8 CRITICAL
CMS Made Simple version 2.1.6 and 2.2 are vulnerable to Smarty templating injection in some core modules, resulting in unauthenticated PHP code execution.
CVE-2017-1000217 1 Opencast 1 Opencast 2026-06-17 6.8 MEDIUM 8.8 HIGH
Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.
CVE-2017-1000052 1 Plug Project 1 Plug 2026-06-17 4.6 MEDIUM 7.8 HIGH
Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection in the Plug.Static component, which may allow users to bypass filetype restrictions.