Improper Authentication vulnerability in Apache APISIX.
On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
CVSS
No CVSS.
References
Configurations
No configuration.
History
01 Oct 2026, 14:17
| Type | Values Removed | Values Added |
|---|---|---|
| References |
|
01 Oct 2026, 12:17
| Type | Values Removed | Values Added |
|---|---|---|
| New CVE |
Information
Published : 2026-10-01 12:17
Updated : 2026-10-01 15:17
NVD link : CVE-2026-94276
Mitre link : CVE-2026-94276
CVE.ORG link : CVE-2026-94276
JSON object : View
Products Affected
No product.
CWE
CWE-287
Improper Authentication
