Improper verification of cryptographic signature vulnerability in Apache APISIX.
Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
CVSS
No CVSS.
References
Configurations
No configuration.
History
01 Oct 2026, 14:17
| Type | Values Removed | Values Added |
|---|---|---|
| References |
|
01 Oct 2026, 12:17
| Type | Values Removed | Values Added |
|---|---|---|
| New CVE |
Information
Published : 2026-10-01 12:17
Updated : 2026-10-01 15:17
NVD link : CVE-2026-94212
Mitre link : CVE-2026-94212
CVE.ORG link : CVE-2026-94212
JSON object : View
Products Affected
No product.
CWE
CWE-347
Improper Verification of Cryptographic Signature
