CVE-2026-93587

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*

History

16 Oct 2026, 18:44

Type Values Removed Values Added
References () https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2v - () https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2v - Vendor Advisory
References () https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-decoder - () https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-decoder - Third Party Advisory
First Time Imagemagick
Imagemagick imagemagick
CPE cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*

18 Sep 2026, 14:19

Type Values Removed Values Added
New CVE

Information

Published : 2026-09-18 14:19

Updated : 2026-10-29 21:17


NVD link : CVE-2026-93587

Mitre link : CVE-2026-93587

CVE.ORG link : CVE-2026-93587


JSON object : View

Products Affected

imagemagick

  • imagemagick
CWE
CWE-400

Uncontrolled Resource Consumption