Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.
This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.
Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
References
| Link | Resource |
|---|---|
| https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557 | Vendor Advisory Mailing List |
| http://www.openwall.com/lists/oss-security/2026/09/23/31 | Mailing List Third Party Advisory |
Configurations
Configuration 1 (hide)
|
History
06 Oct 2026, 13:53
| Type | Values Removed | Values Added |
|---|---|---|
| References | () https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557 - Vendor Advisory, Mailing List | |
| References | () http://www.openwall.com/lists/oss-security/2026/09/23/31 - Mailing List, Third Party Advisory | |
| First Time |
Apache
Apache tomcat Native |
|
| CPE | cpe:2.3:a:apache:tomcat_native:*:*:*:*:*:*:*:* |
23 Sep 2026, 19:19
| Type | Values Removed | Values Added |
|---|---|---|
| References |
|
23 Sep 2026, 16:16
| Type | Values Removed | Values Added |
|---|---|---|
| CVSS |
v2 : v3 : |
v2 : unknown
v3 : 7.5 |
23 Sep 2026, 13:17
| Type | Values Removed | Values Added |
|---|---|---|
| New CVE |
Information
Published : 2026-09-23 13:17
Updated : 2026-10-06 13:53
NVD link : CVE-2026-86243
Mitre link : CVE-2026-86243
CVE.ORG link : CVE-2026-86243
JSON object : View
Products Affected
apache
- tomcat_native
CWE
CWE-126
Buffer Over-read
