CVE-2026-77405

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
CVSS

No CVSS.

Configurations

No configuration.

History

16 Sep 2026, 15:17

Type Values Removed Values Added
New CVE

Information

Published : 2026-09-16 15:17

Updated : 2026-09-24 21:16


NVD link : CVE-2026-77405

Mitre link : CVE-2026-77405

CVE.ORG link : CVE-2026-77405


JSON object : View

Products Affected

No product.

CWE
CWE-326

Inadequate Encryption Strength