Improper Authentication vulnerability in Apache Tomcat. When Jakarta Authentication was configured with SimpleAuthConfigProvider as the default provider and multiple web application used that provider, the realm for the first web application to authenticate a request would be used for all web applications.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M4 through 9.0.121.
The following versions were EOL at the time the CVE was created but are
known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60, 9.0.122, which fixes the issue.
References
Configurations
No configuration.
History
23 Sep 2026, 19:19
| Type | Values Removed | Values Added |
|---|---|---|
| References |
|
23 Sep 2026, 16:16
| Type | Values Removed | Values Added |
|---|---|---|
| CVSS |
v2 : v3 : |
v2 : unknown
v3 : 7.3 |
23 Sep 2026, 12:17
| Type | Values Removed | Values Added |
|---|---|---|
| New CVE |
Information
Published : 2026-09-23 12:17
Updated : 2026-09-23 19:19
NVD link : CVE-2026-75973
Mitre link : CVE-2026-75973
CVE.ORG link : CVE-2026-75973
JSON object : View
Products Affected
No product.
CWE
CWE-287
Improper Authentication
