CVE-2026-75845

ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.
Configurations

No configuration.

History

22 Oct 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) Las versiones de ArcadeDB 26.4.2 a 26.7.3 contienen una vulnerabilidad de omisión de autorización en la herramienta a nivel de servidor MCP set_server_setting. SetServerSettingTool.execute() se basa únicamente en el indicador global allowAdmin y nunca verifica el rol del llamador, por lo que en una implementación MCP con allowAdmin=true y un conjunto de allowedUsers no-root, cualquier usuario autenticado de solo lectura puede invocar set_server_setting para modificar la GlobalConfiguration del servidor, lo que permite la manipulación de la configuración o la denegación de servicio. El problema está solucionado en la versión 26.8.1.

Information

Published : 2026-08-18 12:19

Updated : 2026-10-22 22:10


NVD link : CVE-2026-75845

Mitre link : CVE-2026-75845

CVE.ORG link : CVE-2026-75845


JSON object : View

Products Affected

No product.

CWE
CWE-269

Improper Privilege Management