Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.
The following versions were EOL at the time the CVE was created but are
known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
References
| Link | Resource |
|---|---|
| https://lists.apache.org/thread/8robqo76q0osxgw0b5lcwgz0hcf9h4zc | Mailing List Vendor Advisory |
| http://www.openwall.com/lists/oss-security/2026/08/26/8 | Mailing List Third Party Advisory |
Configurations
Configuration 1 (hide)
|
History
21 Sep 2026, 12:17
| Type | Values Removed | Values Added |
|---|---|---|
| References | () https://lists.apache.org/thread/8robqo76q0osxgw0b5lcwgz0hcf9h4zc - Mailing List, Vendor Advisory | |
| References | () http://www.openwall.com/lists/oss-security/2026/08/26/8 - Mailing List, Third Party Advisory |
Information
Published : 2026-08-25 22:17
Updated : 2026-09-21 12:17
NVD link : CVE-2026-68569
Mitre link : CVE-2026-68569
CVE.ORG link : CVE-2026-68569
JSON object : View
Products Affected
apache
- tomcat
CWE
CWE-287
Improper Authentication
