CVE-2026-62440

Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc Mailing List Vendor Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

16 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de control de acceso inadecuado en el plugin de Kubernetes Service (CKS) de Apache CloudStack, permitiendo la manipulación entre inquilinos del clúster de Kubernetes mientras se añaden y eliminan nodos. Este problema afecta a Apache CloudStack: desde la versión 4.21.0.0 hasta la 4.22.1.0. Se recomienda a los usuarios actualizar a la versión 4.22.1.1 o posterior, que corrige el problema.

Information

Published : 2026-08-21 09:16

Updated : 2026-10-16 15:10


NVD link : CVE-2026-62440

Mitre link : CVE-2026-62440

CVE.ORG link : CVE-2026-62440


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-284

Improper Access Control