CVE-2026-62183

Improper Privilege Management vulnerability in Apache Syncope. When: * the all-Java user workflow adapter is configured, or * the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests the following scenario could happen. A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.
References
Link Resource
https://lists.apache.org/thread/6r8cngvy43y2yk4jj3w060dt8vx0yzpr Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/07/20/9 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*

History

24 Oct 2026, 20:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Gestión Inadecuada de Privilegios en Apache Syncope. Cuando: * el adaptador de flujo de trabajo de usuario all-Java está configurado, o * el adaptador de flujo de trabajo de usuario Flowable está configurado, que contiene una definición BPMN que no requiere aprobación de administrador para el auto-registro de usuario o solicitudes de auto-actualización el siguiente escenario podría ocurrir. Una llamada a la API REST puede permitir al usuario otorgarse a sí mismo uno o más de los Roles definidos, obteniendo así sus Privilegios y convirtiéndose de hecho en un administrador; los Privilegios reales obtenidos dependen de los Roles que están efectivamente definidos en la implementación específica de Syncope. Este problema afecta a Apache Syncope: desde 3.0.0-M0 hasta 3.0.16, desde 4.0.0-M0 hasta 4.0.6, desde 4.1.0-M0 hasta 4.1.1. Se recomienda a los usuarios actualizar a la versión 4.0.7 / 4.1.2, que corrige este problema.

Information

Published : 2026-07-20 15:16

Updated : 2026-10-24 20:10


NVD link : CVE-2026-62183

Mitre link : CVE-2026-62183

CVE.ORG link : CVE-2026-62183


JSON object : View

Products Affected

apache

  • syncope
CWE
CWE-269

Improper Privilege Management