CVE-2026-61397

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's OAuth2 authentication plugin and Google OAuth integration. This issue affects Apache CloudStack: from 4.19.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc Vendor Advisory Mailing List
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

16 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Exposición de Información Sensible a un Actor No Autorizado en el plugin de autenticación OAuth2 de Apache CloudStack y la integración de Google OAuth. Este problema afecta a Apache CloudStack: desde 4.19.0.0 hasta 4.20.3.0 y desde 4.21.0.0 hasta 4.22.1.0. Se recomienda a los usuarios actualizar a la versión 4.20.3.1 o 4.22.1.1, que soluciona el problema.

Information

Published : 2026-08-21 09:16

Updated : 2026-10-16 15:10


NVD link : CVE-2026-61397

Mitre link : CVE-2026-61397

CVE.ORG link : CVE-2026-61397


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-200

Exposure of Sensitive Information to an Unauthorized Actor