CVE-2026-60080

Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0. A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:fory:*:*:*:*:*:*:*:*

History

24 Oct 2026, 20:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad Use After Free en la lógica de deserialización de Rust de Apache Fory. Este problema afecta a Apache Fory desde la versión 0.13.0 hasta la 1.3.0. Una carga útil de Fory manipulada podría causar un comportamiento indefinido, una caída del proceso o una posible divulgación de memoria. Se recomienda a los usuarios actualizar a la versión 1.4.0, que soluciona el problema.

Information

Published : 2026-07-21 12:18

Updated : 2026-10-24 20:10


NVD link : CVE-2026-60080

Mitre link : CVE-2026-60080

CVE.ORG link : CVE-2026-60080


JSON object : View

Products Affected

apache

  • fory
CWE
CWE-416

Use After Free