CVE-2026-59799

Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc Mailing List Vendor Advisory
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

16 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Gestión de Privilegios Inadecuada en el plugin de autenticación de dos factores de Apache CloudStack permitiendo el bypass del flujo de desactivación de la autenticación de dos factores. Este problema afecta a Apache CloudStack: desde 4.18.0.0 hasta 4.20.3.0 y desde 4.21.0.0 hasta 4.22.1.0. Se recomienda a los usuarios actualizar a la versión 4.20.3.1 o 4.22.1.1 o posterior, lo que soluciona el problema.

Information

Published : 2026-08-21 09:16

Updated : 2026-10-16 15:10


NVD link : CVE-2026-59799

Mitre link : CVE-2026-59799

CVE.ORG link : CVE-2026-59799


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-269

Improper Privilege Management