CVE-2026-59780

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's LDAP authentication plugin while listing LDAP providers. LDAP configurations can be listed by any authenticated user with access to the listLdapConfigurations API. By default, this API is available to all default roles. This issue affects Apache CloudStack: from 4.2.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc Vendor Advisory Mailing List
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

16 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Exposición de Información Sensible a un Actor No Autorizado vulnerabilidad en el plugin de autenticación LDAP de Apache CloudStack al listar proveedores LDAP. Las configuraciones LDAP pueden ser listadas por cualquier usuario autenticado con acceso a la API listLdapConfigurations. Por defecto, esta API está disponible para todos los roles predeterminados. Este problema afecta a Apache CloudStack: desde 4.2.0.0 hasta 4.20.3.0 y desde 4.21.0.0 hasta 4.22.1.0. Se recomienda a los usuarios actualizar a la versión 4.20.3.1 o 4.22.1.1 o posterior, que corrige el problema.

Information

Published : 2026-08-21 09:16

Updated : 2026-10-16 15:10


NVD link : CVE-2026-59780

Mitre link : CVE-2026-59780

CVE.ORG link : CVE-2026-59780


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-200

Exposure of Sensitive Information to an Unauthorized Actor