CVE-2026-59084

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

History

24 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) vulnerabilidad de Documentación Técnica Insuficiente en Apache Tomcat ya que los requisitos para configurar de forma segura el EncryptInterceptor no estaban claramente documentados. Este problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.23, desde 10.1.0-M1 hasta 10.1.56, desde 9.0.13 hasta 9.0.119, desde 8.5.38 hasta 8.5.100, desde 7.0.100 hasta 7.0.109. Otras versiones que han llegado al fin de su soporte también pueden verse afectadas. Se recomienda a los usuarios actualizar a la versión 11.0.24, 10.1.57 o 9.0.120 que solucionan el problema.

Information

Published : 2026-07-14 09:16

Updated : 2026-10-24 21:10


NVD link : CVE-2026-59084

Mitre link : CVE-2026-59084

CVE.ORG link : CVE-2026-59084


JSON object : View

Products Affected

apache

  • tomcat
CWE
CWE-1059

Insufficient Technical Documentation