CVE-2026-58188

Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
References
Link Resource
https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d Mailing List Vendor Advisory
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*

History

01 Oct 2026, 18:17

Type Values Removed Values Added
Summary (en) Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.9, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue. (en) Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
References () https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d - Vendor Advisory, Mailing List () https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d - Mailing List, Vendor Advisory

Information

Published : 2026-07-29 10:16

Updated : 2026-10-01 18:17


NVD link : CVE-2026-58188

Mitre link : CVE-2026-58188

CVE.ORG link : CVE-2026-58188


JSON object : View

Products Affected

apache

  • traffic_server
CWE
CWE-787

Out-of-bounds Write