CVE-2026-55957

Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

History

25 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Paso Crítico Faltante en la Autenticación en Apache Tomcat cuando el JNDIRealm estaba configurado para autenticar enlaces usando GSSAPI permitió a los atacantes autenticarse sin proporcionar la contraseña correcta. Este problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.4, desde 10.1.0-M1 hasta 10.1.36, desde 9.0.0.M1 hasta 9.0.100, desde 8.5.0 hasta 8.5.100, desde 7.0.0 hasta 7.0.109. Se recomienda a los usuarios actualizar a la versión 11.0.5, 10.1.37 o 9.0.101, que corrige el problema.

Information

Published : 2026-06-29 21:16

Updated : 2026-10-25 21:10


NVD link : CVE-2026-55957

Mitre link : CVE-2026-55957

CVE.ORG link : CVE-2026-55957


JSON object : View

Products Affected

apache

  • tomcat
CWE
CWE-304

Missing Critical Step in Authentication