CVE-2026-49877

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*

History

25 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de autorización indebida en Apache ActiveMQ. Un usuario autenticado de la Consola Web con bajos privilegios, por defecto, puede acceder a las rutas /admin/* en la Consola Web. La configuración predeterminada de Jetty incorrectamente no limitaba esas rutas solo a los administradores. Este problema afecta a Apache ActiveMQ: antes de 5.19.8, desde 6.0.0 antes de 6.2.7. Se recomienda a los usuarios actualizar a la versión 6.2.7 o 5.19.8, que corrige el problema.

Information

Published : 2026-06-30 11:16

Updated : 2026-10-25 21:10


NVD link : CVE-2026-49877

Mitre link : CVE-2026-49877

CVE.ORG link : CVE-2026-49877


JSON object : View

Products Affected

apache

  • activemq
CWE
CWE-285

Improper Authorization