CVE-2026-49872

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de autenticación incorrecta en Apache APISIX. Cuando el plugin cas-auth se utiliza en una ruta, un atacante posiblemente puede autenticarse con credenciales de una fuente diferente. Este problema afecta a Apache APISIX: desde la 3.0.0 hasta la 3.16.0. Se recomienda a los usuarios actualizar a la versión 3.17.0, que soluciona el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-26 11:10


NVD link : CVE-2026-49872

Mitre link : CVE-2026-49872

CVE.ORG link : CVE-2026-49872


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-287

Improper Authentication