CVE-2026-49231

Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de omisión de autenticación por suplantación en el plugin opa. Un atacante podría reenviar encabezados de identidad suplantados al servicio ascendente aprovechando una configuración no predeterminada en el plugin opa. Esto podría permitir al atacante asumir privilegios más altos en el servicio ascendente. Este problema afecta a Apache APISIX: desde la versión 3.5.0 hasta la 3.16.0. Se recomienda a los usuarios actualizar a la versión 3.17.0, que corrige el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-26 11:10


NVD link : CVE-2026-49231

Mitre link : CVE-2026-49231

CVE.ORG link : CVE-2026-49231


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-290

Authentication Bypass by Spoofing