CVE-2026-49230

Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.  This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

25 Oct 2026, 23:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Validación Incorrecta del Valor de Verificación de Integridad en Apache APISIX. El plugin jwe-decrypt bajo configuración predeterminada es vulnerable a omisión de autenticación. Este problema afecta a Apache APISIX: desde 3.8.0 hasta 3.16.0. Se recomienda a los usuarios actualizar a la versión 3.17.0, que corrige el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-25 23:10


NVD link : CVE-2026-49230

Mitre link : CVE-2026-49230

CVE.ORG link : CVE-2026-49230


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-354

Improper Validation of Integrity Check Value