CVE-2026-49042

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*

History

25 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de validación de entrada indebida en Apache Camel. Este problema afecta a Apache Camel: desde 4.8.0 hasta 4.18.2, desde 4.19.0 hasta 4.20.0. Se recomienda a los usuarios actualizar a la versión 4.18.3, 4.21.0, que soluciona el problema.

Information

Published : 2026-07-06 11:16

Updated : 2026-10-25 15:10


NVD link : CVE-2026-49042

Mitre link : CVE-2026-49042

CVE.ORG link : CVE-2026-49042


JSON object : View

Products Affected

apache

  • camel
CWE
CWE-20

Improper Input Validation