CVE-2026-46588

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*

History

25 Oct 2026, 15:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de validación de entrada indebida en Apache Camel. Este problema afecta a Apache Camel: hasta la 4.14.7, desde la 4.15.0 hasta la 4.18.2, desde la 4.19.0 hasta la 4.20.0. Se recomienda a los usuarios actualizar a la versión 4.14.8, 4.18.3, 4.21.0, que soluciona el problema.

Information

Published : 2026-07-06 11:16

Updated : 2026-10-25 15:10


NVD link : CVE-2026-46588

Mitre link : CVE-2026-46588

CVE.ORG link : CVE-2026-46588


JSON object : View

Products Affected

apache

  • camel
CWE
CWE-20

Improper Input Validation