CVE-2026-46452

Improper Input Validation vulnerability in Apache NimBLE in Mesh Proxy SAR reassembly could result in passing broken data toward application resulting in memory pressure and unstable parsing behavior. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:nimble:*:*:*:*:*:*:*:*

History

24 Oct 2026, 13:10

Type Values Removed Values Added
Summary
  • (es) Una vulnerabilidad de validación de entrada inadecuada en Apache NimBLE en el reensamblaje SAR del Proxy de Malla podría resultar en el paso de datos corruptos hacia la aplicación, lo que resultaría en presión de memoria y un comportamiento de análisis inestable. Este problema afecta a Apache NimBLE: hasta la versión 1.9.0. Se recomienda a los usuarios actualizar a la versión 1.10.0, que corrige el problema.

Information

Published : 2026-07-24 13:18

Updated : 2026-10-24 13:10


NVD link : CVE-2026-46452

Mitre link : CVE-2026-46452

CVE.ORG link : CVE-2026-46452


JSON object : View

Products Affected

apache

  • nimble
CWE
CWE-20

Improper Input Validation