CVE-2026-45815

Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:nimble:*:*:*:*:*:*:*:*

History

24 Oct 2026, 13:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de aserción alcanzable en Apache NimBLE. Una respuesta ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) especialmente diseñada puede activar una aserción en el analizador ATT. La severidad es media ya que esto requiere que el DUT envíe primero una solicitud ATT Read Multiple Variable Request. Este problema afecta a Apache NimBLE: hasta la versión 1.9.0. Se recomienda a los usuarios actualizar a la versión 1.10.0, la cual corrige el problema.

Information

Published : 2026-07-24 13:18

Updated : 2026-10-24 13:10


NVD link : CVE-2026-45815

Mitre link : CVE-2026-45815

CVE.ORG link : CVE-2026-45815


JSON object : View

Products Affected

apache

  • nimble
CWE
CWE-617

Reachable Assertion