CVE-2026-44580

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*

History

26 Oct 2026, 14:10

Type Values Removed Values Added
Summary
  • (es) Next.js es un React framework para construir aplicaciones web full-stack. Desde la versión 13.0.0 hasta antes de la 15.5.16 y 16.2.5, las aplicaciones que usan scripts beforeInteractive junto con contenido no confiable pueden ser vulnerables a cross-site scripting. En las versiones afectadas, el contenido de script serializado no se escapaba de forma segura antes de ser incrustado en el documento, lo que podría permitir que la entrada controlada por el atacante saliera del contexto de script previsto y ejecutara JavaScript arbitrario en el navegador de un visitante. Esta vulnerabilidad está corregida en las versiones 15.5.16 y 16.2.5.

Information

Published : 2026-05-13 18:16

Updated : 2026-10-26 14:10


NVD link : CVE-2026-44580

Mitre link : CVE-2026-44580

CVE.ORG link : CVE-2026-44580


JSON object : View

Products Affected

vercel

  • next.js
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')