CVE-2026-44087

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Verificación Insuficiente de la Autenticidad de los Datos en Apache APISIX. El plugin openid-connect bajo la configuración predeterminada tiene una superficie de ataque que permite al atacante falsificar encabezados de identidad, permitiendo al atacante obtener acceso no autorizado a los recursos protegidos. Este problema afecta a Apache APISIX: desde 2.3 hasta 3.16.0. Se recomienda a los usuarios actualizar a la versión 3.17.0, que corrige el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-26 11:10


NVD link : CVE-2026-44087

Mitre link : CVE-2026-44087

CVE.ORG link : CVE-2026-44087


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-345

Insufficient Verification of Data Authenticity