CVE-2026-44046

Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de uso de fuente menos confiable en Apache APISIX. El atacante puede aprovecharse del plugin wolf-rbac bajo la configuración predeterminada para potencialmente contaminar los registros con información de identidad falsificada y explotar las reglas de control de acceso basadas en IP. Este problema afecta a Apache APISIX: desde la 1.2.0 hasta la 3.16.0. Se recomienda a los usuarios que actualicen a la versión 3.17.0, que corrige el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-26 11:10


NVD link : CVE-2026-44046

Mitre link : CVE-2026-44046

CVE.ORG link : CVE-2026-44046


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-348

Use of Less Trusted Source