CVE-2026-42509

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:*

History

26 Oct 2026, 19:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de Neutralización Incorrecta de la Entrada Durante la Generación de Páginas Web (’cross-site scripting’) en Apache Wicket. Este problema afecta a Apache Wicket: desde 8.0.0 hasta 8.17.0, 9.0.0, desde 10.0.0 hasta 10.8.0. Se recomienda a los usuarios actualizar a la versión 10.9.0, que corrige el problema.

Information

Published : 2026-05-06 10:16

Updated : 2026-10-26 19:10


NVD link : CVE-2026-42509

Mitre link : CVE-2026-42509

CVE.ORG link : CVE-2026-42509


JSON object : View

Products Affected

apache

  • wicket
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')