CVE-2026-39998

Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 11:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de validación de entrada inadecuada en Apache APISIX. El atacante puede aprovecharse de cierta configuración en el plugin forward-auth para suplantar encabezados de identidad. Este problema afecta a Apache APISIX: desde 2.12.0 hasta 3.16.0. Se recomienda a los usuarios actualizar a la versión 3.17.0, que corrige el problema.

Information

Published : 2026-06-19 14:16

Updated : 2026-10-26 11:10


NVD link : CVE-2026-39998

Mitre link : CVE-2026-39998

CVE.ORG link : CVE-2026-39998


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-20

Improper Input Validation