CVE-2026-34501

Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/o8h6c7cq86fplxlnry6c3rn9x0ovq8mv Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/08/06/11 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apr-util:*:*:*:*:*:*:*:*

History

23 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de desbordamiento de búfer basado en montículo en el cliente redis de Apache Portable Runtime Utility. Este problema afecta a Apache Portable Runtime Utility: desde 1.6.0 hasta 1.6.3. Se recomienda a los usuarios actualizar a la versión 1.6.4, que corrige el problema.

Information

Published : 2026-08-06 15:16

Updated : 2026-10-24 16:10


NVD link : CVE-2026-34501

Mitre link : CVE-2026-34501

CVE.ORG link : CVE-2026-34501


JSON object : View

Products Affected

apache

  • apr-util
CWE
CWE-122

Heap-based Buffer Overflow