CVE-2026-33558

Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:kafka:4.0.0:-:*:*:*:*:*:*
cpe:2.3:a:apache:kafka:4.0.0:rc0:*:*:*:*:*:*
cpe:2.3:a:apache:kafka:4.0.0:rc1:*:*:*:*:*:*
cpe:2.3:a:apache:kafka:4.0.0:rc3:*:*:*:*:*:*

History

26 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Se ha identificado una vulnerabilidad de exposición de información en Apache Kafka. El componente NetworkClient registrará información completa de solicitudes y respuestas en el nivel de registro DEBUG en los registros. Por defecto, el nivel de registro está configurado en el nivel INFO. Si el nivel DEBUG está habilitado, la información sensible será expuesta a través del registro de salida de solicitudes y respuestas. Las listas completas de solicitudes y respuestas afectadas son: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse Este problema afecta a Apache Kafka: desde cualquier versión que soporte la API listada anteriormente hasta la v3.9.1, v4.0.0. Aconsejamos a los usuarios de Kafka que actualicen a la v3.9.2, v4.0.1, o posterior para evitar esta vulnerabilidad.

Information

Published : 2026-04-20 14:16

Updated : 2026-10-26 21:10


NVD link : CVE-2026-33558

Mitre link : CVE-2026-33558

CVE.ORG link : CVE-2026-33558


JSON object : View

Products Affected

apache

  • kafka
CWE
CWE-533

DEPRECATED: Information Exposure Through Server Log Files