CVE-2026-33227

Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_web:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:activemq_web:*:*:*:*:*:*:*:*

History

26 Oct 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) Validación y restricción inadecuadas de una vulnerabilidad de nombre de ruta de classpath en Apache ActiveMQ Cliente, Apache ActiveMQ Broker, Apache ActiveMQ All. En dos instancias (al crear un consumidor Stomp y también al navegar por mensajes en la consola web), un valor de ’key’ proporcionado por un usuario autenticado podría construirse para recorrer el classpath debido a la concatenación de rutas. Como resultado, la aplicación está expuesta a una vulnerabilidad de carga de recursos de ruta de classpath que podría encadenarse con otro ataque para conducir a un exploit. Este problema afecta a Apache ActiveMQ Cliente: anterior a 5.19.3, desde 6.0.0 anterior a 6.2.2; Apache ActiveMQ Broker: anterior a 5.19.3, desde 6.0.0 anterior a 6.2.2; Apache ActiveMQ All: anterior a 5.19.3, desde 6.0.0 anterior a 6.2.2. Se recomienda a los usuarios actualizar a la versión 5.19.4 o 6.2.3, que corrige el problema. Nota: 5.19.3 y 6.2.2 también corrigen este problema, pero eso está limitado a entornos que no son Windows debido a un error de resolución de separador de ruta corregido en 5.19.4 y 6.2.3.

Information

Published : 2026-04-07 09:16

Updated : 2026-10-26 22:10


NVD link : CVE-2026-33227

Mitre link : CVE-2026-33227

CVE.ORG link : CVE-2026-33227


JSON object : View

Products Affected

apache

  • activemq_web
  • activemq
  • activemq_broker
CWE
CWE-22

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')