CVE-2026-31923

Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/0pjs72l7qj83j3srw1l1toyj24bsgkds Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/04/14/1 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de transmisión en texto claro de información sensible en Apache APISIX. Esto puede ocurrir debido a que ’ssl_verify’ en la configuración del plugin openid-connect está configurado como ’false’ por defecto. Este problema afecta a Apache APISIX: desde la versión 0.7 hasta la 3.15.0. Se recomienda a los usuarios actualizar a la versión 3.16.0, que soluciona el problema.

Information

Published : 2026-04-14 09:16

Updated : 2026-10-26 21:10


NVD link : CVE-2026-31923

Mitre link : CVE-2026-31923

CVE.ORG link : CVE-2026-31923


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-319

Cleartext Transmission of Sensitive Information