CVE-2026-31908

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/sob643s5lztov7x579j8o0c444t36n6b Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/04/14/3 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

History

26 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de inyección de encabezado en Apache APISIX. El atacante puede aprovechar cierta configuración en el plugin forward-auth para inyectar encabezados maliciosos. Este problema afecta a Apache APISIX: desde la 2.12.0 hasta la 3.15.0. Se recomienda a los usuarios actualizar a la versión 3.16.0, que corrige el problema.

Information

Published : 2026-04-14 09:16

Updated : 2026-10-26 21:10


NVD link : CVE-2026-31908

Mitre link : CVE-2026-31908

CVE.ORG link : CVE-2026-31908


JSON object : View

Products Affected

apache

  • apisix
CWE
CWE-75

Failure to Sanitize Special Elements into a Different Plane (Special Element Injection)