CVE-2026-29129

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
References
Link Resource
https://lists.apache.org/thread/r4h1t6f8xhxsxfm6c2z5cprolsosho3f Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/04/09/22 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

History

26 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de orden de preferencia de cifrado configurado no preservado en Apache Tomcat. Este problema afecta a Apache Tomcat: desde 11.0.16 hasta 11.0.18, desde 10.1.51 hasta 10.1.52, desde 9.0.114 hasta 9.0.115. Se recomienda a los usuarios actualizar a la versión 11.0.20, 10.1.53 o 9.0.116, que solucionan el problema.

Information

Published : 2026-04-09 20:16

Updated : 2026-10-26 21:10


NVD link : CVE-2026-29129

Mitre link : CVE-2026-29129

CVE.ORG link : CVE-2026-29129


JSON object : View

Products Affected

apache

  • tomcat
CWE
CWE-327

Use of a Broken or Risky Cryptographic Algorithm