CVE-2026-28812

UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate privileges. Users are recommended to upgrade to version 2.12.4 or newer which fixes this issue.
References
Link Resource
https://lists.apache.org/thread/n3m666d6t6871dldvz3ct49ooqkbgw2p Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2026/07/30/15 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*

History

23 Oct 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) La falta de comprobaciones en UserManager permite la suplantación de identidad en Apache JSPWiki hasta la versión 2.12.3, lo que puede permitir a los atacantes escalar privilegios. Se recomienda a los usuarios actualizar a la versión 2.12.4 o posterior, que soluciona este problema.

Information

Published : 2026-07-30 16:17

Updated : 2026-10-23 22:10


NVD link : CVE-2026-28812

Mitre link : CVE-2026-28812

CVE.ORG link : CVE-2026-28812


JSON object : View

Products Affected

apache

  • jspwiki
CWE
CWE-290

Authentication Bypass by Spoofing