A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122.
The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
CVSS
No CVSS.
References
Configurations
No configuration.
History
20 Oct 2026, 19:17
| Type | Values Removed | Values Added |
|---|---|---|
| References |
|
20 Oct 2026, 14:16
| Type | Values Removed | Values Added |
|---|---|---|
| New CVE |
Information
Published : 2026-10-20 14:16
Updated : 2026-10-21 04:16
NVD link : CVE-2026-101296
Mitre link : CVE-2026-101296
CVE.ORG link : CVE-2026-101296
JSON object : View
Products Affected
No product.
CWE
CWE-304
Missing Critical Step in Authentication
