CVE-2025-66675

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*

History

14 Oct 2026, 21:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de denegación de servicio en Apache Struts, la fuga de archivos en el procesamiento de solicitudes multipart causa el agotamiento del disco. Este problema afecta a Apache Struts: desde 2.0.0 hasta 6.7.4, desde 7.0.0 hasta 7.0.3. Se recomienda a los usuarios actualizar a la versión 6.8.0 o 7.1.1, que soluciona el problema. Está relacionado con https://cve.org/CVERecord?id=CVE-2025-64775 - esta CVE aborda la versión afectada 6.7.4 que faltaba.

Information

Published : 2025-12-10 10:16

Updated : 2026-10-14 21:10


NVD link : CVE-2025-66675

Mitre link : CVE-2025-66675

CVE.ORG link : CVE-2025-66675


JSON object : View

Products Affected

apache

  • struts
CWE
CWE-459

Incomplete Cleanup