CVE-2025-66171

The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can create new VMs using backups of any other user of the environment. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.
References
Link Resource
https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm Mailing List Third Party Advisory
http://www.openwall.com/lists/oss-security/2026/05/09/2 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

30 Sep 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) El plugin de CloudStack Backup tiene una lógica de acceso inadecuada en las versiones 4.21.0.0 y 4.22.0.0. Cualquier persona con acceso autenticado a una cuenta de usuario en entornos de CloudStack 4.21.0.0+, donde este plugin está habilitado y tiene acceso a APIs específicas, puede crear nuevas máquinas virtuales utilizando copias de seguridad de cualquier otro usuario del entorno. Se recomienda a los usuarios del plugin de Backup que utilizan CloudStack 4.21.0.0+ actualizar a la versión 4.22.0.1 de CloudStack, que soluciona este problema.

Information

Published : 2026-05-08 13:16

Updated : 2026-10-07 09:10


NVD link : CVE-2025-66171

Mitre link : CVE-2025-66171

CVE.ORG link : CVE-2025-66171


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-359

Exposure of Private Personal Information to an Unauthorized Actor