CVE-2025-66170

The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup. Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.
References
Link Resource
https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm Mailing List Third Party Advisory
http://www.openwall.com/lists/oss-security/2026/05/09/1 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

History

30 Sep 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) El plugin de CloudStack Backup tiene una lógica de autorización impropia en las versiones 4.21.0.0 y 4.22.0.0. Cualquier persona con acceso autenticado a una cuenta de usuario en entornos de CloudStack 4.21.0.0+, donde este plugin está habilitado y tiene acceso a APIs específicas, puede listar copias de seguridad de cualquier cuenta en el entorno. Esta vulnerabilidad no les permite ver el contenido de la copia de seguridad. Se recomienda a los usuarios actualizar a la versión 4.22.0.1, que corrige el problema.

Information

Published : 2026-05-08 13:16

Updated : 2026-10-07 09:10


NVD link : CVE-2025-66170

Mitre link : CVE-2025-66170

CVE.ORG link : CVE-2025-66170


JSON object : View

Products Affected

apache

  • cloudstack
CWE
CWE-863

Incorrect Authorization